Corrigir erro "Falha ao buscar" com o Google Chrome no Ubuntu e no Linux Mint

Recentemente, ao atualizar seu sistema Ubuntu ou Linux Mint, você pode se deparar com um erro de atualização que diz:

W: Falha ao buscar //dl.google.com/linux/chrome/deb/dists/stable/Release Não foi possível encontrar a entrada esperada 'main / binary-i386 / Packages' no arquivo Release (entrada Wrong sources.list ou arquivo malformado )

E: Alguns arquivos de índice não foram baixados. Eles foram ignorados, ou os antigos usados ​​em seu lugar.

No Ubuntu, o erro parece:

Enquanto no Linux Mint, o Software Updater gera o seguinte erro:

Não se sinta sozinho. Este é um problema comum enfrentado por muitos depois que o Google Chrome terminou o suporte para o sistema Linux de 32 bits. Nós já sabemos disso. Esta mudança deveria impactar apenas sistemas Linux de 32 bits, mas parece que mesmo os usuários que executam o Ubuntu 14.04 ou superior em sistemas de 64 bits também são afetados por essa mudança.

Embora esse erro seja pequeno, trivial, é altamente irritante. A boa notícia é que é realmente fácil livrar-se desse erro doloroso.

Correção Falha ao buscar //dl.google.com/linux/chrome/deb/dists/stable/Release

O problema aqui é que na entrada da lista de fontes, por padrão, ele está esperando o pacote de 32 bits. Este som é estranho, mas é verdade. O que precisamos fazer aqui é alterar a entrada sources.list para o Google Chrome e instruí-lo explicitamente para obter

O que precisamos fazer aqui é alterar a entrada sources.list para o Google Chrome e instruí-la explicitamente para obter o pacote de 64 bits. Como modificar o sources.list, você pode perguntar.

Bem, é muito fácil fazer isso. Isso pode ser feito inteiramente na própria linha de comando, mas mantendo os iniciantes em mente, mostrarei como fazê-lo com um editor de texto gráfico.

Passo 1:

Abra um terminal e use o comando abaixo:

sudo gedit /etc/apt/sources.list.d/google-chrome.list 

Isto irá abrir o editor de texto Gedit e você verá um arquivo como este:

Passo 2:

Aqui, tudo o que precisamos fazer é substituir deb //dl.google.com/linux/chrome/deb/ stable main com a seguinte linha:

 deb [arch=amd64] //dl.google.com/linux/chrome/deb/ stable main 

Deve ficar assim agora:

Etapa 3:

Salve e feche o arquivo. Agora execute a atualização novamente usando o comando abaixo:

 sudo apt-get update 

Você não verá o erro novamente. Desfrute de atualizações sem erros agora :)

Recomendado

Como proteger por senha uma pasta no Linux
2019
Lançamento do Linux Lite 3.0
2019
Jogos fantásticos do Linux e onde encontrá-los
2019